Nikodem Graczewski

OLMIS-5815: Added section about classExtender, Resource, Repository and RepositoryImpl

Well, you're the one who introduced this piece of code...

Well, you're the one who introduced this piece of code...

What were we waiting for here? I would prefer if we didn't slow down our tests if that is not necessary.

What were we waiting for here? I would prefer if we didn't slow down our tests if that is not necessary.

OLMIS-5783: Added missing expect

OLMIS-5815: Update coding conventions

* Added information about Class patter

* Added information about classExtender

* Fixed some typos

    • -46
    • +203
    /docs/conventions-javascript.md
    • -0
    • +7
    /docs/developer-toolkit.md
Can't we just do it now? I would take less time than creating the ticket...

Can't we just do it now? I would take less time than creating the ticket...

Could you create it?

Could you create it?

Correct.

Correct.

Could we also get rid of the number? It's a fragile approach.

Could we also get rid of the number? It's a fragile approach.

OLMIS-5814: Added Do and Don't section to the README
OLMIS-5814: Added Do and Don't section to the README
So would we if the label changed... And I really doubt that we would change something like "This field is required".

So would we if the label changed... And I really doubt that we would change something like "This field is required".

Shouldn't we use table here?

Shouldn't we use table here?

This line would be way clearer (and flexible) if we would specify product and column rather than some name.

This line would be way clearer (and flexible) if we would specify product and column rather than some name.

Shouldn't these be part of some kind of add association modal class?

Shouldn't these be part of some kind of add association modal class?

Could we make a getter out of it?

Could we make a getter out of it?

Could we make this more flexible? Is there something we're waiting for here?

Could we make this more flexible? Is there something we're waiting for here?

Could we make this more flexible? Is there something we're waiting for here?

Could we make this more flexible? Is there something we're waiting for here?

Could we make this into an Input class?

Could we make this into an Input class?

Could we make this selector a default one?

Could we make this selector a default one?

I wonder whether we should make this more specific... What do you think? Displaying errors is something that we have pretty much standardized.

I wonder whether we should make this more specific... What do you think? Displaying errors is something that we have pretty much standardized.

I don't think this belongs here. The name leaves me under the impression that we're only checking whether we can enter the screen.

I don't think this belongs here. The name leaves me under the impression that we're only checking whether we can enter the screen.

Could we add information that we're creating a supply partner without associations

Could we add information that we're creating a supply partner without associations

This... I'm a little hesitant on using this approach for given. I would go with a getter for a field that is a part of the page.

This... I'm a little hesitant on using this approach for given. I would go with a getter for a field that is a part of the page.

Could this button be part of the page?

Could this button be part of the page?

What if we have multiple buttons in the cell?

What if we have multiple buttons in the cell?

Could this be based on column header name instead?

Could this be based on column header name instead?

OLMIS-5814: Added Do and Don't section to the README

Updated reference-ui versions