one-network-referencedata-extension

Clone Tools
  • last updated a few minutes ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Released service version 0.0.1-RC1

I think you can rename this to processBufferedData

I think you can rename this to processBufferedData

you can remove "this"

you can remove "this"

you can remove "this"

you can remove "this"

as above

as above

you don't need to use this

you don't need to use this

synchronized will not be needed here if you use synchronized list

synchronized will not be needed here if you use synchronized list

I think you should use Collections.synchronizedList()

I think you should use Collections.synchronizedList()

I don't think we need to return the status here, because it will always be true it can be void and you can use @ResponseStatus(HttpStatus.OK) to return the status

I don't think we need to return the status here, because it will always be true
it can be void and you can use @ResponseStatus(HttpStatus.OK) to return the status

you don't need to return anything here, the response it's not used in the extension you can use the @ResponseStatus(HttpStatus.OK) annotation to return the status

you don't need to return anything here, the response it's not used in the extension
you can use the @ResponseStatus(HttpStatus.OK) annotation to return the status

The status will always be false, so I don't this it's needed

The status will always be false, so I don't this it's needed

I'm not sure, it would be better if we had some other controller (config or integration controller) and we could move it there and enabling/disabling scheduler would be done in a service and called...

I'm not sure, it would be better if we had some other controller (config or integration controller) and we could move it there and enabling/disabling scheduler would be done in a service and called in the new controller

ok, but it's not fetching the products, it's receiving them

ok, but it's not fetching the products, it's receiving them

I think we should change the name of this method, it should indicate that it will clear the existing queue

I think we should change the name of this method, it should indicate that it will clear the existing queue

Why are you using queue here, I think it might be simpler to use synchronized list

Why are you using queue here, I think it might be simpler to use synchronized list

Yes, you're right

Yes, you're right

why are you extending the abstract queue here? This should be more like a service interface than a collection

why are you extending the abstract queue here?
This should be more like a service interface than a collection

which place will be better? data should be sent immediately after turning on the integration.

which place will be better? data should be sent immediately after turning on the integration.

the scheduler sends the file to sftp. Here the service only gets product that has been edited by the users and passes them to the buffer

the scheduler sends the file to sftp. Here the service only gets product that has been edited by the users and passes them to the buffer

I'm not sure if this should be done here

I'm not sure if this should be done here

I think it should be "Send unprocessed data when disabling scheduler"

I think it should be "Send unprocessed data when disabling scheduler"

I think sendOrderable works better here, because you're sending the orderables to ftp server, not fetching it

I think sendOrderable works better here, because you're sending the orderables to ftp server, not fetching it

I think you should rename this method

I think you should rename this method

I don't think you need to create a file here, you can rename the method in the csv service to 'generateCsv' or something similar and return a String, then create a byte array input stream from the ...

I don't think you need to create a file here, you can rename the method in the csv service to 'generateCsv' or something similar and return a String, then create a byte array input stream from the string

I don't think queue should be a service, I think you should rename it

I don't think queue should be a service, I think you should rename it

this type of queue has a fixed size (32 by default) and it will replace the oldest items when it's full, I don't think it's what you want to do

this type of queue has a fixed size (32 by default) and it will replace the oldest items when it's full, I don't think it's what you want to do

why this is in the domain package? it's just a DTO, right?

why this is in the domain package? it's just a DTO, right?

OLMIS-7304: Added sending orderable to one-network-integration-service
OLMIS-7304: Added sending orderable to one-network-integration-service