one-network-integration-ui

Clone Tools
  • last updated a few minutes ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
Released one-network-integration-ui v0.0.1-RC2

Revert "Released one-network-integration-ui v0.0.1-RC1"

Released one-network-integration-ui v0.0.1-RC1

OLMIS-7397: Revert changes made in tests
OLMIS-7397: Revert changes made in tests
OLMIS-7397: Revert changes made in tests

This reverts commit af04eab1f2f24e0c91c452483b1dc20f9eca0f43.

OLMIS-7314: Fix tests after karma upgrade
OLMIS-7314: Fix tests after karma upgrade
OLMIS-7314: Fix tests after karma upgrade

OLMIS-7314: Add Webpack and migrate Grunt build to Webpack
OLMIS-7314: Add Webpack and migrate Grunt build to Webpack
OLMIS-7314: Update scss files to enable webpack build

I think you can rename this to processBufferedData

I think you can rename this to processBufferedData

you can remove "this"

you can remove "this"

you can remove "this"

you can remove "this"

as above

as above

you don't need to use this

you don't need to use this

synchronized will not be needed here if you use synchronized list

synchronized will not be needed here if you use synchronized list

I think you should use Collections.synchronizedList()

I think you should use Collections.synchronizedList()

OLMIS-7312: Refactored code after changes on backend

I don't think we need to return the status here, because it will always be true it can be void and you can use @ResponseStatus(HttpStatus.OK) to return the status

I don't think we need to return the status here, because it will always be true
it can be void and you can use @ResponseStatus(HttpStatus.OK) to return the status

you don't need to return anything here, the response it's not used in the extension you can use the @ResponseStatus(HttpStatus.OK) annotation to return the status

you don't need to return anything here, the response it's not used in the extension
you can use the @ResponseStatus(HttpStatus.OK) annotation to return the status

The status will always be false, so I don't this it's needed

The status will always be false, so I don't this it's needed

I'm not sure, it would be better if we had some other controller (config or integration controller) and we could move it there and enabling/disabling scheduler would be done in a service and called...

I'm not sure, it would be better if we had some other controller (config or integration controller) and we could move it there and enabling/disabling scheduler would be done in a service and called in the new controller

ok, but it's not fetching the products, it's receiving them

ok, but it's not fetching the products, it's receiving them

I think we should change the name of this method, it should indicate that it will clear the existing queue

I think we should change the name of this method, it should indicate that it will clear the existing queue