openlmis-ui-components

Clone Tools
  • last updated a few seconds ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
OLMIS-7516: React table style improvements
OLMIS-7516: React table style improvements
OLMIS-7546 Add config for pouchdb-find
OLMIS-7546 Add config for pouchdb-find
done

done

done

done

as above

as above

add a semicolon here

add a semicolon here

OLMIS-7515 Fix integer parsing
OLMIS-7515 Fix integer parsing
I intenionally do not use props destructing to have all parameters explicitly set

I intenionally do not use props destructing to have all parameters explicitly set

renamed, default value is now empty string as it's proper value for html inputs

renamed, default value is now empty string as it's proper value for html inputs

Unless additional docs and linters are introduced it's better to have all parameters explicitly listed

Unless additional docs and linters are introduced it's better to have all parameters explicitly listed

done

done

allowNegative don't have to be a parameter here, you can access it directly

allowNegative don't have to be a parameter here, you can access it directly

change this to { ...props }

change this to

{ ...props }
I think you should remove the className and onBlur properties and instead add "...props" at the end and later deconstruct it on the input component

I think you should remove the className and onBlur properties and instead add "...props" at the end and later deconstruct it on the input component

You should rename this property to value, so it's consistent with other inputs, also I don't this it should have default value You can also rename the property, like it's done in the InputCall: "va...

You should rename this property to value, so it's consistent with other inputs, also I don't this it should have default value
You can also rename the property, like it's done in the InputCall: "value: initialValue"

fixed

fixed

you should not remove this import, because it's used in the code

you should not remove this import, because it's used in the code

OLMIS-7508: Show validation on table page numbers
OLMIS-7508: Show validation on table page numbers
OLMIS-7515 Add numeric input
OLMIS-7515 Add numeric input
OLMIS-7508: Add validation on product addition table
OLMIS-7508: Add validation on product addition table