openlmis-ui-components

Clone Tools
  • last updated a few seconds ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
OLMIS-5815: Update coding conventions
OLMIS-5815: Update coding conventions
OLMIS-5815: Added sections about ObjectMapper and OpenlmisArrayDecorator

OLMIS-5815: Added section about classExtender, Resource, Repository and RepositoryImpl

Bumped ui-components version to 7.0.1-SNAPSHOT

Released ui-components version 7.0.0

OLMIS-5815: Update coding conventions

* Added information about Class patter

* Added information about classExtender

* Fixed some typos

    • -46
    • +203
    /docs/conventions-javascript.md
    • -0
    • +7
    /docs/developer-toolkit.md
Bumped version to 7.0.0-SNAPSHOT

7.0.0-RC1 release

OLMIS-5356: Made .note and gap styling more generic
OLMIS-5356: Made .note and gap styling more generic
OLMIS-5356: Made .note and gap styling more generic

OLMIS-5356: Changed the condition for when page should be reloaded when using pagination
OLMIS-5356: Changed the condition for when page should be reloaded when using pagination
OLMIS-5356: Changed the condition for when page should be reloaded when using pagination

moved

moved

OLMIS-5356: Extended OpenlmisArrayDecorator with getAllWithUniqueIds method

added

added

done

done

I left small comments, I think this is ready for QA

I left small comments, I think this is ready for QA

IDK, supply partner association service?

IDK, supply partner association service?

I think those 2 above are appearing if tables are empty? then they should have period to

I think those 2 above are appearing if tables are empty? then they should have period to

You mean the last two messages, right?

You mean the last two messages, right?

any proposition of a new name?

any proposition of a new name?

I would keep Admin prefix because of module name

I would keep Admin prefix because of module name

I don't think we need this 'Admin' prefix

I don't think we need this 'Admin' prefix