Mateusz Kwiatkowski

I would say that ConfimationModal should be used in ViewRequsitionPage, we should just pass messages to this new class. Make confirmation modal as button etc. is done in components directory.

I would say that ConfimationModal should be used in ViewRequsitionPage, we should just pass messages to this new class. Make confirmation modal as button etc. is done in components directory.

hmm maybe this should be moved to ViewRequisitionPage? Łukasz Lewczyński Nikodem Graczewski

hmm maybe this should be moved to ViewRequisitionPage?
Łukasz Lewczyński Nikodem Graczewski

please change String type to all lowercase

please change String type to all lowercase

please add jsdocs

please add jsdocs

I think that this need translation

I think that this need translation

how about some jsdocs?

how about some jsdocs?

Is there a reason why those inputs do not have id property?

Is there a reason why those inputs do not have id property?

I would change both, also for consistency reasons as other methods start with 'with' prefix

I would change both, also for consistency reasons as other methods start with 'with' prefix

I was thinking of just adding this css direct to select2 without referencing openlmis-facility-program-select

I was thinking of just adding this css direct to select2 without referencing openlmis-facility-program-select

OLMIS-5616: added description for what should be covered by which type of tests
OLMIS-5616: added description for what should be covered by which type of tests
Still, we should have specific ticket referenced only once, please merge those 2 entries.

Still, we should have specific ticket referenced only once, please merge those 2 entries.

I think this should still be callled 'withPartnerNode'

I think this should still be callled 'withPartnerNode'

I think this parameter should be named 'node' instead of 'childNodes'.

I think this parameter should be named 'node' instead of 'childNodes'.

why this should be different than regular select?

why this should be different than regular select?

changelog?

changelog?