Łukasz Lewczyński

OLMIS-6358: Extracted orderable meta to new class
OLMIS-6358: Extracted orderable meta to new class
missing information in what situations the repository should not find inactive ftaps

missing information in what situations the repository should not find inactive ftaps

Okay, I see but it is incorrect. Currently, you add this to the INNER JOIN step but this is not related with joining FTAP and facility types tables. This should be in the where phrase because your ...

Okay, I see but it is incorrect. Currently, you add this to the INNER JOIN step but this is not related with joining FTAP and facility types tables. This should be in the where phrase because your check is related only with FTAP table.

I don't think that this will work. This should be in the where phrase

I don't think that this will work. This should be in the where phrase

OLMIS-6351: Dropped reference to orderable version from FTAP
OLMIS-6351: Dropped reference to orderable version from FTAP
We could test that check the method works for string values

We could test that check the method works for string values

We should use timezone from settings.

We should use timezone from settings.

now tests pass https://review.openlmis.org/static/ogdo0b/2static/images/wiki/icons/emoticons/smile.gif

now tests pass

done

done

OLMIS-6317: Service account tokens will not expire
OLMIS-6317: Service account tokens will not expire
some of them are used in functional tests

some of them are used in functional tests

I think the same and maybe because of that some functional tests fail

I think the same and maybe because of that some functional tests fail

Not sure why this is required. I don't see a field with such class type.

Not sure why this is required. I don't see a field with such class type.

Should we also adjust the UI?

Should we also adjust the UI?

Should we change the name to SYSTEM_NOTIFICATIONS_MANAGE?

Should we change the name to SYSTEM_NOTIFICATIONS_MANAGE?

missing entries in messages.properties file

missing entries in messages.properties file

done

done

could we add a short description (as a comment) why we provided this change? Also, I am not sure if this should be in the validator class. Maybe this should be done earlier/another layer. The valid...

could we add a short description (as a comment) why we provided this change? Also, I am not sure if this should be in the validator class. Maybe this should be done earlier/another layer. The validator should only validate data, it should not modify them

Probably because we wanted to reuse existing steps that require the period name in those tests.

Probably because we wanted to reuse existing steps that require the period name in those tests.