Klaudia Pałkowska

OLMIS-6399: Fixed button label at filter component on system notifications screen
OLMIS-6399: Fixed button label at filter component on system notifications screen
OLMIS-6399: Adjusted UI after renaming openlmis.administration.systemNotification state to...
OLMIS-6399: Adjusted UI after renaming openlmis.administration.systemNotification state to...
I didn't find any place where we are comparing dates from the database to the current timestamp, but I replaced hardcoded zone with SQL function NOW().

I didn't find any place where we are comparing dates from the database to the current timestamp, but I replaced hardcoded zone with SQL function NOW().

Because it's better in my opinion and it was the original idea from what I remember.

Because it's better in my opinion and it was the original idea from what I remember.

I thought that our database stores ZonedDateTimes in UTC.

I thought that our database stores ZonedDateTimes in UTC.

Yes, I've adjusted UI.

Yes, I've adjusted UI.

OLMIS-6388: Refactored searching system notifications by isDisplayed flag and setting mentioned flag...
OLMIS-6388: Refactored searching system notifications by isDisplayed flag and setting mentioned flag...
Shouldn't we add assert for author field to check whether it is expanded?

Shouldn't we add assert for author field to check whether it is expanded?

OLMIS-6347: Moved injecting timeZoneId from params to builder
OLMIS-6347: Moved injecting timeZoneId from params to builder
OLMIS-6350: Added cutting long messages and fixed displaying users in the filter
OLMIS-6350: Added cutting long messages and fixed displaying users in the filter
Yes, in the UI ticket.

Yes, in the UI ticket.

Yes, we decided to avoid the "message" word.

Yes, we decided to avoid the "message" word.

OLMIS-6347: Added CRUD for administrative messages
OLMIS-6347: Added CRUD for administrative messages
OK, let's leave it as it is.

OK, let's leave it as it is.

Is it merged with some other test?

Is it merged with some other test?

Shouldn't we change the name of the feature to describe what we are actually testing?

Shouldn't we change the name of the feature to describe what we are actually testing?

Could you add the migration file comment that should be generated?

Could you add the migration file comment that should be generated?

Please add changelog.

Please add changelog.

OLMIS-6253: Updated missing integration tests to use data builders
OLMIS-6253: Updated missing integration tests to use data builders
Shouldn't we use something like this: code: "code" + random.nextInt(),

Shouldn't we use something like this:

code: "code" + random.nextInt(),