I'm getting similar issues as Jasmine 1.x when making proposed changes. I don't think this is the right way to go, so I'm going to close this review.

I'm getting similar issues as Jasmine 1.x when making proposed changes. I don't think this is the right way to go, so I'm going to close this review.

Merged into one.

Merged into one.

Removed.

Removed.

Will do https://review.openlmis.org/static/ogdo0b/2static/images/wiki/icons/emoticons/wink.gif

Will do

What do you think about the new name?

What do you think about the new name?

That will be done, but will be in a separate review.

That will be done, but will be in a separate review.

Could we change the name to more descriptive?

Could we change the name to more descriptive?

Remove this inline-style.

Remove this inline-style.

Only one button should be marked as primary for a specific screen.

Only one button should be marked as primary for a specific screen.

User Array.prototype.map instead.

User Array.prototype.map instead.

User Array.prototype.map instead.

User Array.prototype.map instead.

This isn't consistent with the rest of the table forms. Please rework this to use 'openlmis-invalid' directive inside the table. Also, wrap the table element in form and update the "Save Kit Unpack...

This isn't consistent with the rest of the table forms. Please rework this to use 'openlmis-invalid' directive inside the table. Also, wrap the table element in form and update the "Save Kit Unpack List" to be a submit button of the said form.

Why using the apply here?

Why using the apply here?

Please user FunctionDecorator.

Please user FunctionDecorator.

Change the key so it matches the message.

Change the key so it matches the message.

Change key to "adminProductView.kitUnpackList".

Change key to "adminProductView.kitUnpackList".

Change key to "adminProductView.createKitUnpackList".

Change key to "adminProductView.createKitUnpackList".

According to our style guide, it should say what we are saving.

According to our style guide, it should say what we are saving.

Please, use OrderableResource instead.

Please, use OrderableResource instead.

It can simply be "ids.length".

It can simply be "ids.length".

Please add unit tests for this file.

Please add unit tests for this file.

Please, use Array.prototype.map instead.

Please, use Array.prototype.map instead.

What is the "c"? Could we give it a more meaningful name?

What is the "c"? Could we give it a more meaningful name?