Clone
 

paweł gesek <pgesek@soldevelo.com> in openlmis-report

OLMIS-2871: Remove redundant spaces

OLMIS-2871: Fix param order in tests

OLMIS-2871: Switch param order

OLMIS-2871: Update report serrvice to use auth headers

* Updated RAML

* Switched ref data calls to use auth header

    • -1
    • +8
    /src/main/resources/api-definition.yaml
OLMIS-1939: Mention how to set require ssl to false

OLMIS-1939: Fixed copy/paste issue TRANSIFEX_USER -> TRANSIFEX_PASSOWRD

OLMIS-1939: Added Transifex vars

OLMIS-1939: Added database variables

OLMIS-1939: Mentioned that SSL is not required by default

OLMIS-1939: Fixed typos in README

OLMIS-1939: Emphasize var names

OLMIS-1939: Added an environment variable section

OLMIS-1686: Made the LICENSE-HEADER.md look better

Add "for example" to license header exampel text

OLMIS-1686: Information about adding the LICENSE-HEADER

OLMIS-1686: Added license header to java files

OLMIS-1686: Add checkstyle check for copyright header

Added more info about the override file

Linked to the Docker site explaining the way docker-compose.override.yml is used

README: Mentioned required Docker Compose version

Ran into https://github.com/docker/compose/issues/3209 - since compose syntax 2 is used, Compose 1.6 is required.

Source: https://blog.docker.com/2016/02/compose-1-6/.