openlmis-functional-tests

Clone Tools
  • last updated a few seconds ago
Constraints
Constraints: committers
 
Constraints: files
Constraints: dates
OLMIS-6314: Fixed broken tests

Probably because we wanted to reuse existing steps that require the period name in those tests.

Probably because we wanted to reuse existing steps that require the period name in those tests.

Do you know why do we even need the period name in those tests? Can't we just proceed the requisition with the only available period there?

Do you know why do we even need the period name in those tests? Can't we just proceed the requisition with the only available period there?

OLMIS-6314: Fixed compilation error

Looks good

Looks good

OK, let's leave it as it is.

OK, let's leave it as it is.

OLMIS-6314: Fixed compilation error

please, check https://review.openlmis.org/cru/FEOLMIS-3826

please, check https://review.openlmis.org/cru/FEOLMIS-3826

Is this change required every month?

Is this change required every month?

OLMIS-6314: Improved emergency requisition features
OLMIS-6314: Improved emergency requisition features
OLMIS-6314: Removed unnecessary steps in skipping authorization step feature
OLMIS-6314: Removed unnecessary steps in skipping authorization step feature
I think the name is okay. Why do you think we should change it? Any proposition for a new name?

I think the name is okay. Why do you think we should change it? Any proposition for a new name?

we have other tests that also check if a user is able (or not) to add non-full supply products. You can find an example in requisition-submit.feature

we have other tests that also check if a user is able (or not) to add non-full supply products. You can find an example in requisition-submit.feature

OLMIS-6314: Improved emergency requisition features

    • -0
    • +9
    /src/support/lib/getCurrentMonthlyPeriodName.js
    • -0
    • +10
    /src/support/lib/getCurrentQuarterlyPeriodName.js
Is it merged with some other test?

Is it merged with some other test?

Shouldn't we change the name of the feature to describe what we are actually testing?

Shouldn't we change the name of the feature to describe what we are actually testing?

OLMIS-6314: Removed unnecessary steps in skipping authorization step feature

OLMIS-6314: Reduced number of requisition tests
OLMIS-6314: Reduced number of requisition tests
OLMIS-6314: Bumped period code for emergency requisition

OLMIS-6314: Added missing import statement

OLMIS-6314: Reduced number of requisition tests

Some tests did exactly the same things and check different parts of

requisition workflow.

  1. … 14 more files in changeset.
Fixed issue with incorrect XPath selector